Uploaded image for project: 'i2b2 Web Client'
  1. i2b2 Web Client
  2. WEBCLIENT-150

Find - After Searching, the disappearing "Searching..." text logic is incorrect

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.7.06
    • Fix Version/s: 1.7.07
    • Component/s: None
    • Labels:
      None
    • Affects View/s:
      Find Terms
    • i2b2 Sponsored Project/s:
      i2b2 Web Client
    • Testing Notes:
      Hide
      TEST STATUS: Completed
      COMPLETION DATE: 12/07/2015

      ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

      Test Date: 12/07/2015
      Build Number:1.7.07
      Test Status: Completed (Passed Testing)
      Clients Tested :
           i2b2 Web Client
           

      Environments Tested :
           Browsers: Chrome, Firefox, Internet Explorer, and Safari
           Databases: Not applicable for this test
           Client OS: Windows, Mac

      Test Comments:Searching text appears only in ontology terms currently. testing scope is limited to that panel only.
      orking as expected
      Note : currently there is no searching text display in previous queries/find panel
      Tested upto max 2000 count. Since above that count, webclient is hanging on search( known issue)
      ISSUES FOUND:None
      Show
      TEST STATUS: Completed COMPLETION DATE: 12/07/2015 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++ Test Date: 12/07/2015 Build Number:1.7.07 Test Status: Completed (Passed Testing) Clients Tested :      i2b2 Web Client       Environments Tested :      Browsers: Chrome, Firefox, Internet Explorer, and Safari      Databases: Not applicable for this test      Client OS: Windows, Mac Test Comments:Searching text appears only in ontology terms currently. testing scope is limited to that panel only. orking as expected Note : currently there is no searching text display in previous queries/find panel Tested upto max 2000 count. Since above that count, webclient is hanging on search( known issue) ISSUES FOUND:None

      Description

      In Search by Names, after clicking on Find, there is a "Searching..." text that appears and disappears (when the search query is returned).

      The logic is incorrect and the "Searching..." text disappears 3 seconds after the last AJAX fire, regardless of whether the callback took place. This makes it appear that the search operation is completed, but it is not yet.

      This will be fixed in 1.7.07

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code