Uploaded image for project: 'i2b2 Core Software'
  1. i2b2 Core Software
  2. CORE-82

Compile and run errors in Workbench 1.6.0.9 with Eclipse 4.3.1 and Java 1.7/1.6

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 1.6.00
    • Fix Version/s: None
    • Component/s: Install, Workbench
    • Labels:
      None
    • Environment:
      Ubuntu Linux 10.04, kernel version 2.6.35-32-generic, Eclipse 4.3.1, jdk1.7.0 with java-6-sun-1.6.0.26 as an alternative.
    • Rank:
      0|i000pb:

      Description

      I followed the instructions here: https://www.i2b2.org/software/files/PDF/current/i2b2Workbench_Developers_Guide.pdf

      There were components besides edu.harvard.i2b2.eclipse that had JRE compliance explicitly set, and they were all set to 1.5. The remaining components defaulted to 1.7. I tried continuing with the build instructions nonetheless and there were build errors as follows:

      edu.harvard.i2b2.eclipse/

              src/ProjectManagementRequestData.java, lines 16, 17, 35, 144
                  (it seems I am missing org.apache.commons.logging.Log and org.apache.commons.logging.LogFactory)

              META-INF/MANIFEST.MF, lines 11, 28, 29, 39, 39

      edu.harvard.i2b2.eclipse.plugins.workplace/
              META-INF/MANIFEST.MF, line 26


      I refreshed and went through the run configurations setup and attempted running edu.harvard.i2b2.eclipse as per instructions, and it would not launch. I went through all the projects and manually changed their compliance, making sure to replace JRE 1.7 with 1.6 in their build paths. Then I re-built. The build errors were in the same places as before and are in the attached build log. Also attached is the stack trace from my final attempt.

        Attachments

          Activity

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code