Space shortcuts
Space Tools

Versions Compared


  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 5.3

This page contains all the caveats and the known workarounds that we are aware of.  Please read through each one to determine if any applies to your particular environment and situation.  Thanks.

Researcher's Guide 

We have provided a Guide (http://micard.umassmed.edu/downloads/The_New_ExportXLS_plugin_for_i2b2_(MiCARD)_webclient.pdf) for this plugin to our researchers in University of Massachusetts Medical School. We welcome anyone who may find it useful to the researchers in their own institutions as well.

Ignore Excel Warning Dialog

When opening the resulting exported HTML-coded Excel file (.xls), a dialog similar to the following may be displayed:
Simply click [Yes] to proceed.

Different Browser Type may Exhibit Different HTML-coded Excel Spreadsheet Exportation Behaviors

In our development and testing efforts, we've noticed that when the data is exported to the HTML-coded Excel spreadsheet, the behaviors vary among the 4 different browser types (Firefox, Chrome, IE, and Safari). These differences are not anything that can be controlled through our codes (at least not anything we're aware of, though we'll be grateful if any one can suggest any specific workable improvements).

For instance, the following excerpt is from Yves Thorrez (Universitair Ziekenhuis Brussel) on the behaviors of IE:

"However, what's still annoying is that in IE, ... a new tab is opened with an empty page...

 When I go back to the i2b2 tab, there is an IE popup asking to open or save the file, so that's ok."

php.ini Setting and Resulting Exported HTML-coded Excel Spreadsheet File

Gregory Schulte (Children's Hospital Colorado) has alerted us that if the "short_open_tag" in the /etc/php.ini file of the i2b2 server is NOT set to "on", then the resulting exported HTML-coded Excel spreadsheet may be just a blank file.

He also suggested the following alternatives as workaround options (for those who have encountered this "blank file" problem, else one need not do anything):

  • either change the "short_open_tag" in the /etc/php.ini file
    No Format
                     short_open_tag = On
  • or change line 15 of the SaveToExcel.php file,
    No Format
    No Format
                     <body><?php echo $_REQUEST['datatodisplay']?>

Of these, we recommend updating the /etc/php.ini file.
BTW, after either change, as Yves Thorrez (Universitair Ziekenhuis Brussel) reminded us, one must clear the browser cache (close & restart browser session) to ensure the change takes effect.

Furthermore, if this "blank file" problem persists, then try the following:

  1. check for and remove any extraneous "short_open_tag = Off" lines in the /etc/php.ini file
  2. check for and remove any extraneous "short_open_tag = Off" lines in other files in the /etc/php.d directory
  3. try to restart both the php-fpm (if applicable) & the Apache services:
    No Format
    /etc/init.d/php-fpm restart, (or service php-fpm restart)
    /etc/init.d/httpd restart, (or service httpd restart)
  4. then run
    No Format
    chkconfig httpd on
    chkconfig php-fpm on
  5. then check to ensure:
    No Format
    php \-i \| grep short_open_tag
    should result in something like short_open_tag => On => On

Incidentally, we determined that this caveat also existed for v1.0-2.0 of this web client plugin.
We do hope to have an updated SaveToExcel.php file (that takes care of this caveat without requiring the deployers to update their /etc/php.ini files) included in the next release of this web client plugin.